Tunearo | Music distribution, done right!
Resolved
All releases will be queued for distribution shortly.
Identified
We're aware of the issue causing this issue. Any releases pending to be delivered will be queued when fixed.
Investigating
Delivery to DSPs are currently slower than usual. We're looking into this.