Tunearo | Music distribution, done right!
Resolved
We've fixed this issue. If you're still having trouble submitting a release, please refresh the page, then if you're still having issues contact support.
Monitoring
We're monitoring the fix to ensure it has fully resolved the issue. So far, we've submitted 10 test releases, and all were successfully submitted with a single click, as intended.
Identified
We've found what's causing this issue, and are developing a fix now.
Investigating
To submit a release, users may be required to click "Submit release" multiple times. We're investigating this issue.